Selespeed faults - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 12-01-08 Thread Starter
Status: -
Join Date: Jan 2008
Location: near Aberdeen
Posts: 2
Selespeed faults


I drive a 2002 147 Selespeed which has developed some rather annoying faults, such as - Selespeed System & VDC warning lights come on randomly, auto-switches to City mode when driving along, randomly doesn't allow engagement of gears, etc. The car has been into the dealer workshop twice, and although they reset any faults (none of which they consider to be major), it's not long before they come back. Can anyone recommend a workshop near Aberdeen that specialises in Alfas, and their "unique" electonics?

kasco is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: Selespeed faults

Hi Kasco welcome to AO. Check out our tech lounge for your 147.
classicgal93 is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Selespeed faults

Hello and welcome to AO.
rammy is offline  
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: Selespeed faults

Said many times before, but is it a relatively new, and assuredly good, battery??:
zulu ferret is offline  
Status: Bring on the Giulia
AO Platinum Member
OperationAlfa's Avatar
Join Date: May 2007
Location: United Kingdom
County: Essex
Posts: 23,176
Re: Selespeed faults

(moved to 147 tech lounge)
OperationAlfa is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Re: Selespeed faults

As ZF said, the Selespeed needs a good battery and as you also have VDC errors it does point to that.

If you still have the original 2002 battery it will be well past its best by now.
Average battery life is about 4-years.

Also very important to check the Selespeed fluid level.
Best to check it weekly, ie at the same time as you check the engine oil level, hopefully you are already checking the engine oil...
David C is offline  
Status: -
AO Member
Join Date: Jan 2008
Location: United Kingdom
County: Northamptonshire
Posts: 224
Re: Selespeed faults

Does it randomly not select any any gears or certain ones i.e. 1st 3rd and 5th or R 2nd and 4th?

Id ask them to check the clutch anyway as this cured all of my similar faults. Had my car in for clutch alignment which cured it for a little while then came back. If your garage are doing the same then the clutch maybe the issure in which case it'l cost around the £500 mark to get it fixed by a garage. Which isn't as bad as £1000+for actuator or new pump etc.

ChrisSound is offline  
(Post Link) post #8 of 8 Old 14-01-08 Thread Starter
Status: -
Join Date: Jan 2008
Location: near Aberdeen
Posts: 2
Re: Selespeed faults

Thanks for the battery tips. I'll check it out when I get home
kasco is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

faults , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome