Dropped coolant - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 03-09-16 Thread Starter
Status: -
AO Member
 
Join Date: Jul 2016
Location: Reading
County: Berkshire
Dropped coolant

Currently awaiting break down truck after 147 GTA dumped its coolant - managed to pull over swiftly so hopefully ok. What's usually the cause on these cars - perished hoses? Faulty clips? Burst rad? Thanks.
trashy is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 6 Old 03-09-16 Thread Starter
Status: -
AO Member
 
Join Date: Jul 2016
Location: Reading
County: Berkshire
Turns out that the front lower metal coolant pipe is corroded. Could be a lot worse!
trashy is offline  
Status: now a diesel head..
AO Silver Member
 
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Glad you caught it quickly..fingers crossed its fine..
joeymannero is offline  
 
Status: Bring on the Giulia
AO Platinum Member
 
OperationAlfa's Avatar
 
Join Date: May 2007
Location: United Kingdom
County: Essex
Garage
Very common. Autolusso do a stainless steel replacement. Recommended.
OperationAlfa is offline  
Status: tax bill....bah!
AO Silver Member
 
goremohekan's Avatar
 
Join Date: Sep 2012
Location: United Kingdom
County: Kent
Garage
Quote:
Originally Posted by OperationAlfa View Post
Very common. Autolusso do a stainless steel replacement. Recommended.
I've a decent s/h original if you want a cheapo repair option.... not knocking the stainless pipe though....I fitted one when changing the rad....plus their silicon pipes....

just realised mine is from a 156 GTA....pretty sure it's the same...

Last edited by goremohekan; 03-09-16 at 20:27.
goremohekan is offline  
(Post Link) post #6 of 6 Old 03-09-16 Thread Starter
Status: -
AO Member
 
Join Date: Jul 2016
Location: Reading
County: Berkshire
Thanks everyone - I ordered a s/s replacement from Autolusso this afternoon
trashy is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
coolant , dropped

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome