Alfa 147 Central Locking Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 27-08-16 Thread Starter
Status: -
Newbie
 
Join Date: Aug 2016
County: -
Posts: 1
Alfa 147 Central Locking Problem

We have had our 2003 147 TS for a few months and it has been great, up until this morning...

Went to unlock the car and it unlocks but immediately locks itself again. Same if I try with the key.

I don't want to unlock it and open the door just before it locks itself for having an uncontrollable alarm but will need to investigate later.

Anyone have any ideas?
SidewaysSi is offline  
Sponsored Links
Advertisement
 
Status: Working Hard On 156 Veloce 3.0 Turbo Project
AO Silver Member
 
mirlock's Avatar
 
Join Date: Mar 2014
Location: United Kingdom
County: Northamptonshire
Posts: 1,242
http://www.alfaowner.com/Forum/searc...rchid=16108145

Sounds like a door switch or boot switch thats either open or reporting the lock is open .

Last edited by mirlock; 27-08-16 at 17:30.
mirlock is offline  
Status: -
AO Member
 
Gruna86's Avatar
 
Join Date: Dec 2015
Location: Kotor
County: Montenegro
Posts: 14
Quote:
Originally Posted by SidewaysSi View Post
We have had our 2003 147 TS for a few months and it has been great, up until this morning...

Went to unlock the car and it unlocks but immediately locks itself again. Same if I try with the key.

I don't want to unlock it and open the door just before it locks itself for having an uncontrollable alarm but will need to investigate later.

Anyone have any ideas?
I have the same problem. Disconnect battery for half hour and you are good for some time. When it happens again,disconnect the battery again.
Gruna86 is offline  
 
Status: waiting for summer
AO Member
 
Thomassima's Avatar
 
Join Date: Jul 2016
Location: Finland
Posts: 36
Garage

Member car:

147 1.6 TS '04

I also had this problem, it was caused by right rear door not fully closed. The solution was to hold a plastic bag filled with hot water on the door lock a few minutes or so. It was -20C not sure what temperatures you have there
Thomassima is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
147 , alfa , central , locking , problem

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome