Bye Bye Alfa - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 09-01-08 Thread Starter
Status: -
Join Date: Jan 2008
Posts: 4
Bye Bye Alfa

Hi All

Afraid is time to say bye bye to my Alfa it started with my dash lighting up like a Xmas tree just before christmas thought my babe was getting into the festive mood. ECU light i think not a tech head so forgive my ignorance Alfa stuttering when stationary but ok once moving up & down gears but stuttering when stationar & moving off in first. Then gearbox warning light came on left car standing over xmas & new year Battery died until cash available. Eventualy found a garage that would look at her on to diagnostic & 14 faults 8 cleared sparious faults thrown up by dead battery 4 other remaining again forgive my ignorance Lamda sensor, sensor that mointors air temperature both fixed a third sensor fixed cannot remember name gearbox still not sorted fourth sensor think clutch senors in gearbox looks like a hacksaw has had a go at it. Mech has said in his opinion the gearbox has a major fault for this to have happened to the sensor & that probaly the clutch fly wheel ? is hitting or rubbing against sensor. Please any suggestions, opinions similiar problems this is truly my first love beautiful 156 2.0L Selespeed pearlesant colour never seen the like before or probaly again.

Heeeeeeeeeeeeeeelp Pleeeeeeeeeeeaaaaaasssssssssse
mick2786 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , bye

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome