Strange noise from front of car using heater - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 25-08-16 Thread Starter
Status: -
AO Member
 
Join Date: Aug 2016
Location: Helhoughton
County: Norfolk-
Posts: 12
Strange noise from front of car using heater

Please excuse my ignorance but I have a problem that I can't work out and one that my mechanic won't even attempt to rectify.
I have a 156 Sportwagon 2001 and the heater blower is not working. I purchased a replacement before checking the old one out. When I did change them over there was no difference so it wasn't that. While I was nosing about my son was turning the blower on and off for me and he did it once while I was outside .
Basically every time the switch is moved there is a click at the front drivers side of the car behind the headlight. I can in no way be called knowledgeable about cars so I am reaching out again.
I have not even had chance to drive the car myself the mechanic took it for an mot and it has sat on the drive ever since it came home.
Please any help will be very gratefully received.
Best regards, Alan.
oddjobber23 is offline  
Sponsored Links
Advertisement
 
Status: Why bother with 3 cylinders when 6 will do?
AO Silver Member
 
Mymatemarmite's Avatar
 
Join Date: Sep 2012
Location: United Kingdom
County: Devon
Posts: 1,828
If the A/C is switched on then each time you turn the blower unit on you'll hear the clutch on the A/C compressor engage. It's not directly behind the headlamp but sounds do have a way of travelling. It may be this?
Mymatemarmite is offline  
Status: -
AO Member
 
Join Date: Jul 2014
Location: Scotland
County: Falkirk
Posts: 633

Member car:

147

What was it you replaced, the heater blower, the control panel or the variable resistor ?

And yes the aircon may be clicking as its switched on and off as mentioned above
Davffc is offline  
 
(Post Link) post #4 of 4 Old 25-08-16 Thread Starter
Status: -
AO Member
 
Join Date: Aug 2016
Location: Helhoughton
County: Norfolk-
Posts: 12
Quote:
Originally Posted by Davffc View Post
What was it you replaced, the heater blower, the control panel or the variable resistor ?

And yes the aircon may be clicking as its switched on and off as mentioned above
Thank you. I replaced the resistor and the motor. When the blower is turned on I get a click at the resistor. I have put on a new one and the same thing happens. I have tested both motors off the car and both spin freely with no wobbles or anything.
Regards, Alan
oddjobber23 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
car , front , heater , noise , strange

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome