Cam belt/ rocker arms ? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 16-08-16 Thread Starter
Status: -
AO Member
Join Date: Apr 2016
County: -
Posts: 14
Cam belt/ rocker arms ?

Hey guys. After fixing the sluggish/turbo lag on my gt jtd I've now got an almost dead baby sitting on the driveway! ?
Driving along at around 30mph with minimal load on the engine I see smoke coming from the wheel arch and smell burning rubber, stop to look and see cam belt is rubbing on the engine cover, not good I says, turns out possibly the water pump has failed and thrown the timing!!! Garage quoted 1600 just to change valves and cam belt etc without actually seeing if calves are bent! Nearly all the rocker arms are snapped/cracked so my question to you geniuses is, could I have gotten away with just changing the rockers and cambelt/ water pump kit? I think I actually done the damage by trying to restart again not when it was actually driving!
Cambelt was changed at 72000 it's now got 10300 but no doubt everything else was left as factory fit!
Any suggestions from you guys is much appreciated
Dave wroe is offline  
Sponsored Links
Status: Race cars in progress
Club Member
Membro Premio
Gertie's Avatar
Club Member Number: 2201
Join Date: Oct 2007
Location: South Africa
County: Gauteng
Posts: 5,261
Images: 6
It sounds as if that motor is toast. Contact Autolusso if they have a replacement motor:

Autolusso - Online Shops
Gertie is offline  
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,864
Valves should be okay so new rockers, belt and waterpump. Make sure you get all the bits of the old rockers out of the engine. All the above depends on the exact engine you have, some newer ones are not quite as easy.
Rockhopper is offline  
(Post Link) post #4 of 5 Old 17-08-16 Thread Starter
Status: -
AO Member
Join Date: Apr 2016
County: -
Posts: 14
It's the 1.9 engine. 2004 so think it's the cf3 engine? Spoke to go-italia (local specialist) and he thinks I might have gotten away with it the belt didn't actually snap only jumped the timing! Waiting for a quote from him as we speak! Fingers crossed!!!
Dave wroe is offline  
Status: Flaps? What flaps?
AO Silver Member
_The_Editor_'s Avatar
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,205
Autolusso put these back together as a past time...

In fact they even have it as a fixed price service listed on their website -

Rockers are purposefully weaker than the valves, so they should fail (relatively easy repair) and the rest of the valvetrain remains relatively undamaged...

A new set of rockers and a full cambelt kit will usually see you right and on the road again, possibly some other bits too if it needs it... If you take it to a non-specialist you may end up getting charged for a bunch of parts/labour that you don't need! Best case scenario, the head won't even need to come off.. Just the valve cover!

I'd get it recovered over to Autolusso and let them have a look.. Likelihood is they'll diagnose it and fix it cheaper and quicker than most other garages in the country!

_The_Editor_ is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

arms , belt or , cam , rocker

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome