156 2.4 JTD 10v engine management warning on acceleration. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-08-16 Thread Starter
Status: -
AO Member
Yellow Peril156's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Norfolk
Posts: 211
Images: 2
156 2.4 JTD 10v engine management warning on acceleration.

Ever since I've owned my 156, when accelerating from lowish revs (especially in 4th and top) the engine management warning comes on and momentarily cuts the revs - which can be a little hairy when overtaking. It will sometimes do it in third but generally you can rev through it. I spoke to a mapping (specialist?) the other day who was particularly unhelpful and he said there was nothing he could do (or I suspect couldn't be bothered to do).

Any ideas, suggestions please?

Thanks Terry
Yellow Peril156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

10v , 156 , acceleration , engine , jtd , management , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome