Cutting out at 90 degrees - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 24-07-16 Thread Starter
Status: -
Join Date: Apr 2011
Location: Australia
County: New South Wales
Posts: 1

Member car:


Cutting out at 90 degrees

147 2.0 litre twin spark 2002.

I've read a lot of posts there is a lot of talk about the crankshaft sensor but nothing much about coolant temp sensor.

Fault = car will cut out at 90 degrees then restart when cold.

Plugged into to diagnostic:
P0335 Crankshaft sensor - defective
P0336 Crankshaft sensor - outside specified range.
P0115 Coolant Temp Sensor - defective
P0130 O2 sensor (bank1 sensor1) - defective
P1135 O2 sensor heater resistance (bank1 sensor1) - incorrect value

Do you think the 1 sensor will be throwing the other sensors out? or all the sensors are faulty?

cheers for any advice.

Last edited by kiteman; 24-07-16 at 04:37.
kiteman is offline  
Sponsored Links
Status: Thinking about giulia veloce
Club Member
Membro Premio
jwq's Avatar
Club Member Number: 857
Join Date: Jan 2005
Location: The Netherlands
County: Zuid Holland
Posts: 4,103
Images: 16
I would replace the crankshaft sensor, reset the errors and see if that also solves the other problems .....
jwq is offline  
Status: if it works, take it apart to finde out why
AO Silver Member
GTV-TB's Avatar
Join Date: Dec 2008
Location: Sweden
County: Skåne
Posts: 1,015

Member car:


Replace crankshaft sensor and coolant temp sensor (check wiring to temp sensor first so they are ok), clear the faults and reset adaptive values, drive the car and see if O2 sensor faults do return they may be caused by a
faulty coolant temp sensor.
GTV-TB is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cutting , degrees

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome