156 Airbag Light (this again) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 31-12-07 Thread Starter
Status: -
AO Silver Member
Nicky's Avatar
Join Date: Apr 2007
Location: United Kingdom
County: Surrey
Posts: 3,269
Images: 5
156 Airbag Light (this again)

I know, it's been done to death, but still. My airbag light came on today and won't go off. Normally it flashes a few times when I start the car and then it goes off, today it flashed then stayed on. I did get into gear and start moving more quickly than usual (ie while the light was still flashing), but I don't know if this would have any effect.

I pulled in after about a minute to switch off the engine and start it again in the hope this would clear it, but it was still on. Also switched the passenger airbag off and on again with the key when I got home but this didn't clear it. What's the likely cause of this? It's a 1999 V6 SP3 and so has Driver and Passenger airbags but no side airbags, hence no airbag connector under the seat to go wrong (I assume).

Can it be cleared by disconnecting the battery, or does it need Alfadiag (or God forbid a trip to the dealer) to solve it?

My Flickr Photos | Leave late, drive fast
2002 147 2.0 Twin Spark Lusso . . . . . . . . . . . . . . . . . . 156 2.5 V6 SP3 Q2 - Gone but not forgotten

For Sale - Pair of 156 headlights. PM if interested
Nicky is offline  
Sponsored Links
Status: -
AO Member
colinbull's Avatar
Join Date: Nov 2005
Location: United Kingdom
County: Hampshire
Posts: 330
Images: 24
Re: 156 Airbag Light (this again)

As i understand on our early models once the light comes on it needs resetting on a diagnostic tool.

Mine has been on for ages now - i Cable tied the plugs under the seat to see if it helped but the light stayed on. (2000 V6)
colinbull is offline  
Status: -
Join Date: May 2007
Posts: 3

Member car:

Alfa Romeo 156

Re: 156 Airbag Light (this again)

Mine came on once I had satellite tracking installed. Never managed to get it off. Diagnostics test does not see any fault with airbags. 1999 / 156 2.0 TS
rajko@iptv-net. is offline  
Status: -
AO Member
Join Date: Aug 2007
Location: United Kingdom
County: Derbyshire
Posts: 243
Images: 7
Re: 156 Airbag Light (this again)

Mine recently came on - 2004/156 1.9 JTDM-Jet
Andrew Lusso is offline  
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: 156 Airbag Light (this again)

resetting the airbag ecu requires an examiner (not sure if alfadiag can do it) but there is no point resetting it until after you fix the fault. so first you need to read the fault code(s) from the airbag ecu. then you need to repair the faults. airbag fault codes usually narrow down the fault to one quarter of the system (seriously they're crap) so then you need to do some further live testing using resistors. its easy to DIY, but a dealer can do it best because they have an idiots guide telling them exactly what to do step by step. so lets imagine you find the fault and fix it (99% of the time a bad connection), then you get the airbag ecu reset. now all is going well and the light is off, but for how long? from past experience my money is on less than 48hours.
jug is offline  
Status: -
AO Member
Join Date: Jun 2009
Location: United Kingdom
County: -
Posts: 26
Images: 1

Member car:

Alfa 156 TS

It seems like this is an alfa problem, i'v had the same problem on the last 3 i'v owned, 2 145's and now a 156. On the 145 I had it cleared and a week later it came on, it has also did the same on my 156. Its a pain but on the 156 I have now put a small piece of black insulation tape over it which you cannot see because I gave up.
1988del is offline  
Status: -
Join Date: Oct 2010
Location: United Kingdom
County: Hampshire
Posts: 1

Member car:

156 T-Spark

Air Bag Dash lights


I new here and need advise on my ***** 156 T-spark Y plate
Recently both the passenger and driver airbag lights have come on and this is worrying me.
I have taken it in for a diag test which cleared it although no fault was found however the next day it came back on.

I will be returning it to the same garage however there seems to be an intermitent problem with the dash electrics as sometimes the background dash lights will not come on and then if i go over a bump they all come on including the doors etc and then clear leaving the background dash and unfortunately the airbag lights. Being a girl even this sounds like a loose or dirty connection????

Can comeone please let me know if this is all connected as also the radio volume moves from one speaker to another occasionally? I did mention this to the garage who seem to think it is unrelated. They also said when ***** romeaos get electrical problems then they continue to get them, is this true?

Please help me
T41b0t is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , airbag , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome