GT motor control system failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 10 Old 18-07-16 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2016
Location: Leicester
County: -Leicestershire
GT motor control system failure

Daughters car threw a warning light this morning. Engine management light basically. Dash says motor control system failure . It drives OK to me but obviously not right.
Car has a big bore throaty exhaust fitted and she said she thought it may have been blowing a bit recently. Is it possible that and the hot weather has taken the system out of the parameters. Ove red by the management system computer?
I cleaned the maf with the correct spray and disconnected the battery for twenty minutes to reset the Ecu to no avail.
Any suggestions as to where I should start looking for the cause of the fault? I don't have a fault code reader unfortunately. Thanks, John.
alfski is offline  
Sponsored Links
Advertisement
 
Status: +o-V-o+
AO Silver Member
 
Giorget2's Avatar
 
Join Date: Jan 2012
Location: South Africa
County: Gauteng
It "could be" that, yes.

Or it could be a myriad of other things.

Without reading the codes, no way to really know except to do troubleshooting one-by-one per item that it could possibly be.

So the short answer is: "Get the codes read."
Giorget2 is offline  
(Post Link) post #3 of 10 Old 18-07-16 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2016
Location: Leicester
County: -Leicestershire
Looks like I will have to get a code reader long term. In the short term the car is booked in to the local exhaust place tomorrow morning to fix the blow on it and we will see if that can fix the issue.
alfski is offline  
(Post Link) post #4 of 10 Old 19-07-16 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2016
Location: Leicester
County: -Leicestershire
Exhaust had some rectification of the mounting system and is sounding much better. Had the air con regassed and it's blowing cold now. Got the fault codes read and the engine management issue is the mass air flow meter. Bought one for forty five quid new from the local motor factors and hoping to get it fitted once it cools down and I finish hauling my new shower and trays upstairs to fit. She should be good to go by tonight with a following wind.
alfski is offline  
Status: -
AO Silver Member
 
t3yls's Avatar
 
Join Date: Aug 2007
Location: Manchester
Images: 4
These cars only seem to like original bosch air flow meters.


Sent from my iPad using Tapatalk
t3yls is offline  
(Post Link) post #6 of 10 Old 19-07-16 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2016
Location: Leicester
County: -Leicestershire
The motor factors one has done the trick. So far so good.
alfski is offline  
(Post Link) post #7 of 10 Old 24-07-16 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2016
Location: Leicester
County: -Leicestershire
Spoke too soon. The gt has got the engine management warning light back on again after her trip south. Cutting out on tickover too now. May have to invest in a fault code reader . Any ideas?
alfski is offline  
Status: -
AO Silver Member
 
t3yls's Avatar
 
Join Date: Aug 2007
Location: Manchester
Images: 4
Quote:
Originally Posted by alfski View Post
Spoke too soon. The gt has got the engine management warning light back on again after her trip south. Cutting out on tickover too now. May have to invest in a fault code reader . Any ideas?

See post number 2!

get a code reader. 15 off the internet and a smartphone and take it from there.


Sent from my iPad using Tapatalk
t3yls is offline  
(Post Link) post #9 of 10 Old 24-07-16 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2016
Location: Leicester
County: -Leicestershire
Slight problem is we all use Apple I phones and not android. Off to search Amazon.
alfski is offline  
Status: -
AO Member
 
Mav666's Avatar
 
Join Date: May 2011
Location: United Kingdom
County: West Cumbria
Garage
Either way afraid its code reader, if you plan to keepe the car for a while, buy a compatible USB reader and install MultiECU, free version will work fine for what you need
Mav666 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
control , failure , motor , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome