alfa 156 airbag light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
  Home Forums AO Club Member Gallery Classifieds Trade Directory  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Reply
 
LinkBack Thread Tools
  #1 (Post Link)  
Old 07-12-06
Status: -
Newbie
 
Join Date: Dec 2006
Posts: 1

Member car:

alfa romeo 156 2.0 TS

alfa 156 airbag light

the airbag light is on in my car, is this a common fault and can i reset it
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (Post Link)  
Old 07-12-06
rarebear's Avatar
Status: Gold Member
AO Gold Member
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 6,922

Member car:

156 Selespeed SP2

Re: alfa 156 airbag light

this is very common ! bad connector under passengerseat mostly, reset yourself ? no you need the examinator box , the Alfa dealer has one.
Reply With Quote
  #3 (Post Link)  
Old 12-12-06
Status: -
Newbie
 
Join Date: Dec 2005
Posts: 6

Member car:

156

Re: alfa 156 airbag light

Beware, when airbag light stays on, the airbags are disabled!!
Reply With Quote
  #4 (Post Link)  
Old 12-12-06
russ's Avatar
Status: -
AO Member
 
Join Date: Nov 2006
Location: United Kingdom
County: Lincolnshire
Posts: 101

Member car:

156 selespeed

Re: alfa 156 airbag light

Airbag light will remain on if the passenger airbag is de-activated - There's a slot for your key to activate / re-activate this in the passenger door opening.
Reply With Quote
  #5 (Post Link)  
Old 12-12-06
gazza82's Avatar
Status: adjusted exhaust,still knocks! :-(
AO Gold Member
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 7,399
Images: 12

Member car:

'98 156 2.0, '09 MiTo 1.4

Re: alfa 156 airbag light

There are two airbag lights: one for the overall system (which is the one likely to be the one on now) and the other to indicate the status of the passenger airbag. The Key slot is to activate/deactivate the passenger airbag when you have a reverse-facing childseat.

It doesn't reset the system though - you will need to hook it up to the diagnostic system.
Reply With Quote
  #6 (Post Link)  
Old 12-12-06
Status: -
Newbie
 
Join Date: Dec 2006
Location: Costa del Sandancer
Posts: 14

Member car:

156 2.0 TS, MGB V8, BMWs

Re: alfa 156 airbag light

That's oneof the faults mine has - I've only had it a week. When I test drove the car, it had to be started off a booster. A new battery was subsequently fitted and the lights reset. However, upon collection, the passenger airbag light was flashing quickly. The car has had to go back for a gearbox problem and is being looked into.

It would appear that the fault is a liitle more deep seated on mine as simply resetting the light does not make it go away. With the passenger airbag active or deactivated the light stays on. The car has been taken to an Alfa specialist, so I 'm sure it's going to get sorted.

Interesting to hear about the passenger seat sensor though.

Cheers,

Dougy
Reply With Quote
  #7 (Post Link)  
Old 12-12-06
gazza82's Avatar
Status: adjusted exhaust,still knocks! :-(
AO Gold Member
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 7,399
Images: 12

Member car:

'98 156 2.0, '09 MiTo 1.4

Re: alfa 156 airbag light

Jump starting an Alfa can cause electrical problems .. sounds like they may have fried the airbag ecu!
Reply With Quote
  #8 (Post Link)  
Old 12-12-06
rarebear's Avatar
Status: Gold Member
AO Gold Member
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 6,922

Member car:

156 Selespeed SP2

Re: alfa 156 airbag light

There is a sensor pad in the passenger seat, you can feel it when you move you fingers on the seat, feels like little buttons, its a plastic sheet with sensors (costs a bundle to replace because the upholstery has to be taken off !!).
Reply With Quote
  #9 (Post Link)  
Old 29-11-08
Status: -
Newbie
 
Join Date: Oct 2007
Posts: 15

Member car:

Alfa 156

Thumbs Up Re: alfa 156 airbag light

The Flashing second (passenger) airbag light indicates that somebody has tampered with the airbag failure light. I know because that is what happened when I unsoldered the main airbag LED in order to get my car through the MOT (thought it might fail if tester noticed air bag failure) Anyway, soon as I unsoldered the LED the other one started flashing rapidly.
Reply With Quote
  #10 (Post Link)  
Old 29-11-08
Status: -
Unregistered
 
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646

Member car:

S/w 'Dave' & a Selespeed

Re: alfa 156 airbag light

unidiag or alfadiag can be used, in conjunction with aKKL interface to reset the airbag system
Reply With Quote
  #11 (Post Link)  
Old 14-12-08
Status: -
Newbie
 
Join Date: Nov 2008
Location: United Kingdom
County: -
Posts: 11

Member car:

Alfa 156

Re: alfa 156 airbag light

Hi to you all. Does someone who lives in bedfordshire or surrounding areas have an alfa diag kit that they would be willing to reset my air bag light for me?.
Cheers Jas..........
Reply With Quote
  #12 (Post Link)  
Old 14-12-08
GTA Jim's Avatar
Status: -
Club Member
Membro Premio
 
Club Member Number: 474
Join Date: Apr 2007
Location: Holbeach
Posts: 14,565
Images: 3

Member car:

147 GTA Q2 AD INTAKE

Re: alfa 156 airbag light

Originally Posted by bluejas101 View Post
Hi to you all. Does someone who lives in bedfordshire or surrounding areas have an alfa diag kit that they would be willing to reset my air bag light for me?.
Cheers Jas..........
This might not be the best place to post this request matey, maybe put it in your regional lounge
Reply With Quote
  #13 (Post Link)  
Old 14-12-08
CJO CJO is offline
Status: Enjoying a nice mug of tea
Club Member
Membro Premio
 
Club Member Number: 614
Join Date: Oct 2008
Location: United Kingdom
County: Bedfordshire
Posts: 1,747

Member car:

1.9 JTDm GT Blackline

Re: alfa 156 airbag light

Originally Posted by bluejas101 View Post
Hi to you all. Does someone who lives in bedfordshire or surrounding areas have an alfa diag kit that they would be willing to reset my air bag light for me?.
Cheers Jas..........
Go and see the guys at Auto Lusso - near Dunstable.
Reply With Quote
  #14 (Post Link)  
Old 14-12-08
GTA Jim's Avatar
Status: -
Club Member
Membro Premio
 
Club Member Number: 474
Join Date: Apr 2007
Location: Holbeach
Posts: 14,565
Images: 3

Member car:

147 GTA Q2 AD INTAKE

Re: alfa 156 airbag light

I should have thought of that
Reply With Quote
  #15 (Post Link)  
Old 14-12-08
Status: -
Unregistered
 
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646

Member car:

S/w 'Dave' & a Selespeed

Re: alfa 156 airbag light

Originally Posted by mattbfc2386 View Post
the airbag light is on in my car, is this a common fault and can i reset it
there are TWO airbag lights:

* RED in the 'info-centre' is the main system light, if on the Entire airbag system is disabled.

* Yellow in the Speedo means that ONLY the passengers side airbag disabled symbol...... there is a key switch at the side of the glovebox/dash

to communicate you need software from either AlfaDiag Alfa Romeo Diagnostic Software or KWP71 from the yahoo/unidiag forum & a KKL interface from ebay.
Reply With Quote
  #16 (Post Link)  
Old 15-12-08
Status: -
Newbie
 
Join Date: Nov 2008
Location: United Kingdom
County: -
Posts: 11

Member car:

Alfa 156

Re: alfa 156 airbag light

Hi, Thanks I'm off to Dunstable. sorry if I upset anyone. Cheers Jas....
Reply With Quote
  #17 (Post Link)  
Old 15-12-08
StescoG66's Avatar
Status: 2014 . . . .Year of the Sprint??
AO Silver Member
 
Join Date: May 2007
Location: United Kingdom
County: East Dunbartonshire
Posts: 3,076
Images: 17

Member car:

Me Giuily/Sprint 1.7QV

Re: alfa 156 airbag light

In my car it's the connector in the boot that causes the problem. Check the wee panel on the rhs of the boot and clean those connections.
Worked for me - just be careful when you do so
Reply With Quote
  #18 (Post Link)  
Old 09-06-09
Status: -
Newbie
 
Join Date: Jun 2009
Location: United Kingdom
County: -
Posts: 26
Images: 1

Member car:

Alfa 156 TS

The airbags are NOT disabled, some people say they are but they aren't, the same goes with the ABS light. My 145 ABS light has been on for 2 weeks but ABS still works. Don't try the airbags out though!!
Reply With Quote
  #19 (Post Link)  
Old 09-06-09
crespo2121's Avatar
Status: [Too Long]
AO Silver Member
 
Join Date: Oct 2008
Location: United Kingdom
County: Dorset
Posts: 1,109

Member car:

Honda Accord 2.0 i-vtec

Originally Posted by 1988del View Post
The airbags are NOT disabled, some people say they are but they aren't, the same goes with the ABS light. My 145 ABS light has been on for 2 weeks but ABS still works. Don't try the airbags out though!!
Sorry mate but if the airbag light is on it means the system is dissabled.
And if the car has been jump started in then you have more than likely fried the airbag ecu.
Happened on both my 156's.
Sounds like your abs light is faulty.
When my ABS light came on (blown fuse) the ABS defo did not work.
Reply With Quote
  #20 (Post Link)  
Old 10-06-09
Status: -
Newbie
 
Join Date: May 2008
Posts: 8

Member car:

Alfa 156 Selespeed

The airbags are NOT disabled. Last november i collided with my 156 and yes airbags worked as they should even with airbag warning light on.
Reply With Quote
  #21 (Post Link)  
Old 10-06-09
machvingtsun's Avatar
Status: -
AO Member
 
Join Date: Sep 2008
Location: Ireland
County: -
Posts: 75

Member car:

156

According to Elearn the airbags may be disabled if the airbag warning light is on.
Reply With Quote
  #22 (Post Link)  
Old 10-06-09
rarebear's Avatar
Status: Gold Member
AO Gold Member
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 6,922

Member car:

156 Selespeed SP2

Originally Posted by ronnande View Post
The airbags are NOT disabled. Last november i collided with my 156 and yes airbags worked as they should even with airbag warning light on.


IMPOSSIBLE !!! when the AB light is on there is no power to the crash sensor and thus
no reaction .... you must be that one in a million case !
Reply With Quote
  #23 (Post Link)  
Old 10-06-09
Status: -
Unregistered
 
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646

Member car:

S/w 'Dave' & a Selespeed

if the RED light is on the system is dis-abled.

if the yellow is on ONLY the passenger side is disabled
Reply With Quote
  #24 (Post Link)  
Old 10-06-09
TOX1C's Avatar
Status: GTA Lives Again - Yes really!!
Club Member
Membro Premio
 
Club Member Number: 343
Join Date: Aug 2004
Location: United Kingdom
County: Wiltshire
Posts: 3,158
Images: 5

Member car:

156 GTA & 20v SportWagon

Originally Posted by StescoG66 View Post
In my car it's the connector in the boot that causes the problem. Check the wee panel on the rhs of the boot and clean those connections.
Worked for me - just be careful when you do so
Same for me, last time the light came on I thumped the plastic cover in the boot and it went off and has stayed off, but having said that ................ there is always tomorrow!
Reply With Quote
  #25 (Post Link)  
Old 11-06-09
TOX1C's Avatar
Status: GTA Lives Again - Yes really!!
Club Member
Membro Premio
 
Club Member Number: 343
Join Date: Aug 2004
Location: United Kingdom
County: Wiltshire
Posts: 3,158
Images: 5

Member car:

156 GTA & 20v SportWagon

Yup, true to form after 3 months or so without a light on, and after yesterday's post; YES you've guessed it the light came on today, went off, then on. Gave the same cover a few thumps - off it went, here's hoping for the best tomorrow.
Reply With Quote
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
156, airbag, alfa, light

Thread Tools


Recently 'Read'
No History to show

Useful Links
Lost Password?
AO Merchandise
FAQs
Register

External Links
Alfa Romeo 156...
2009 Alfa Romeo...
2011 Alfa Romeo...
Alfa Romeo GT...
L@@K~JUST...

Alfa Romeo

Recent Image

Img-20140716-wa0003...

View kevingt's images

Search

Forums

Classifieds
   

Gallery

Social Groups
   

Members
   


Did you know..?
Did you know..?
You can change the look and feel of AO by changing your colour scheme

   

New To Site? Need Help?

All times are GMT. The time now is 05:28.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89