Speedometer/odometer problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
  Home Forums AO Club Member Gallery Classifieds Trade Directory  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Reply
 
LinkBack Thread Tools
  #1 (Post Link)  
Old 04-06-06
Status: -
Newbie
 
Join Date: Sep 2004
Location: Mid Wales
Posts: 1

Member car:

Alfa 156 2.0TS

Speedometer/odometer problem

Hello all. The speedometer/odometer on my 2001 156 2.0TS has randomly started to fail. It usually happens within a few miles of a cold start. The speedometer will drop to 0mph and the odometer will stop counting miles. After about 5 minutes or so the speedometer usually springs back into life and stays that way for the rest of the journey. No warning lights come on while this is happening.
Is it true that the 156 gets its speed signal from the ABS computer?

Thanks in advance,
Stephen
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (Post Link)  
Old 05-06-06
Hoygaard's Avatar
Status: cornea come l'inferno
AO Silver Member
 
Join Date: Apr 2002
Location: Denmark
County: Kobenhavn
Posts: 4,156

Member car:

156 GTA SW

Re: Speedometer/odometer problem

Yes, it's true. The ABS unit sends a speed signal to the speedometer. The speedometer then sends the speedsignal to the engine ECU and the climate control unit.

I would suspect the speedometer to be faulty. An intermittent speedo signal would probably trigger the engine ECU to set a fault code and turn on the check engine light.
Reply With Quote
  #3 (Post Link)  
Old 06-11-06
wrinx
Status: - Update
Guest
 
Posts: n/a
Re: Speedometer/odometer problem

My speedo flickered from 60-80 and 80-100 today, only for a few seconds and was fine after.

Any ideas?

wrinx
Reply With Quote
  #4 (Post Link)  
Old 06-02-07
Status: -
Newbie
 
Join Date: Feb 2007
Posts: 2

Member car:

156 1.8TS Volece

Re: Speedometer/odometer problem

I have been experiancing the same problem with my 156, recently had the ABS sensor replaced but warning light will not go out.
Reply With Quote
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
problem, speedometer or odometer

Thread Tools


Recently 'Read'
No History to show

Useful Links
Lost Password?
AO Merchandise
FAQs
Register

External Links
Alfa Romeo 156...
2009 Alfa Romeo...
2011 Alfa Romeo...
Alfa Romeo GT...
L@@K~JUST...

Alfa Romeo

Recent Image

Ao Killarney Meet...

View David P's images

Search

Forums

Classifieds
   

Gallery

Social Groups
   

Members
   


Did you know..?
Did you know..?
You can change the look and feel of AO by changing your colour scheme

   

New To Site? Need Help?

All times are GMT. The time now is 04:17.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89