147 Brakelight failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 12-01-16 Thread Starter
Status: -
AO Member
David.Bain's Avatar
Join Date: Jan 2016
Location: Cape Town
County: South Africa
Posts: 11

Member car:

Alfa 147 1.6 TS

147 Brakelight failure

Hi there hope some one can help. I have a 147 2003 1.6 TS. When I switch on the car and it does a system check I get brakelight failure come up. The problem is all the lights are working. I decided to change all the tale lights just in case no change I checked the 3rd light above the rear window and all the bulbs are working. I checked the number plate lights as well they are fine to. Checked the fuses nothing wrong there eather. Brake light switch is fine as well. Can any one tell me what ells I can have a look at.
David.Bain is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

147 , brakelight , failure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome