clutch probs? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 21-10-07 Thread Starter
Status: -
Join Date: Jun 2007
Location: Cwmbran
Posts: 4

Member car:

Alfa 146Ti

clutch probs?

hi all.

i have a 'P' reg 146ti. i need only rest my foot on the clutch pedal and a loud whirring noise comes somewhere from the engine bay. The noise isn't evident when my foot is not on the pedal.

any idea's?

Kev2505 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Sep 2007
Posts: 21

Member car:

alfa romeo 146

Re: clutch probs?

sounds like either your clutch thrust bearing or input shaft bearing neither are serious probs if you can live with the noise but both require removal of gearbox to fix
paul146 is offline  
Status: ready to race
AO Silver Member
rafe005's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Devon
Posts: 5,244

Member car:

159 1.9jtdm

Re: clutch probs?

I had a thrust bearing go on my old 146 and the noise was always there until i depressed the clutch, then it slowed down and eventually stopped. Thus the opposite to yours. I know its not an answer to your question but maybe you can use my experience to narrow down your possible problems
rafe005 is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Re: clutch probs?

thrust washers???
purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

clutch , probs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome