need help please with my clutch on my 145 cloverleaf - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-06-07 Thread Starter
Status: -
Join Date: Mar 2007
Posts: 7

Member car:

cloverleaf 145

need help please with my clutch on my 145 cloverleaf


Please can someone give me some advice, when i am in traffic my clutch starts sqealling. when i had been driving for a couple of hours the other day, got into a traffic jam and had trouble getting the car into gear and getting the clutch at biting point, I read on one of the forums the other day about the slave cyclinder is this what I might have to replace or does it sound like a new clutch?
robert400 is offline  
Sponsored Links
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: need help please with my clutch on my 145 cloverleaf

Unfortunately, more like a new clutch?:
zulu ferret is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

145 , cloverleaf , clutch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome