146 ti misfire - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 18-05-07 Thread Starter
Status: -
Join Date: Feb 2006
Posts: 8

Member car:

146 ti

146 ti misfire

Hello my 1999 ti is misfireing only on cold engine and only between 2000 and 3000 rpm , as soon as the temperature reach 50 all is gone and the car run fine.
Can it be the variator? ( it does sound like an old diesel when its cold )
Spark plugs ?
Air meater ?
It is a difficoult job to change the plugs ? I never done before just help once my uncle with is alfetta but I was 4 or 5 years old.
alessio is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2003
Location: Bristol
Posts: 5,002
Re: 146 ti misfire

Variator won't cause a misfire, but it could be the plugs. Easy enough to do if you've got the right torx fasteners, just remember that they may have been in a while; I squirted some plus gas into the recesses and left it overnight to minimise teh risk of snapping them off. You'll need a long reach spark plug socket, 14mm IIRC. You might also find that there is oil in the spark plug recess from a weeping cam cover gasket, if there is I would clean that up and see if it helps before worrying about the plugs.
mave is offline  
Status: -
AO Member
warrior146ti's Avatar
Join Date: Nov 2006
Posts: 82

Member car:


Re: 146 ti misfire

Mine is doing the exact same thing. Missfiring at startup for 5 min until warm.

I suspect it's the MAF though. Unplugging it seems to help
warrior146ti is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , misfire

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome