alfa 146ti Pinking when warm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 20-09-14 Thread Starter
Status: -
AO Member
Join Date: Apr 2010
Location: United Kingdom
County: Surrey
Posts: 96

Member car:


alfa 146ti Pinking when warm

During the warmer weather, when at half way temp my 146 ti 2.0 ts is pinking under load, Its really not a good thing any one got any ideas how to reduce or get rid if it completly?

thanks in advance

Attached Images
File Type: jpg 146a.jpg (153.8 KB, 5 views)
lo42 black 944 is offline  
Sponsored Links
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
Are you sure it's pinking? Pinking is usually caused by dodgy petrol or too much advance on the ignition.. more an old-school carbs & points problem.. since modern engines are run by a computer. If you had a knock sensor problem, I'd guess that you'd have other problems with the ignition too.

So....check the physical stuff. HT leads (the metal collars under the rubber boots, where they connect to the coils and plus respectively.

Also check the receiver on the coils where the HT leads attach. Look for "pencil lines" that mean there's been arcing... cracks, burns, scores, meltedness etc.

Remove the spark plugs (go for a longish run first to get the car warmed right up and then don't let it idle when you get back.. just turn it off and let it cool down) .. Look at general plugs condition and for one or more unusual plugs (sootier than the others, oilier, whiter etc) .. If the plug gaps need gapping, gap them. If the expensive plugs are worn out, stick new ones in there.

It might be worth sticking some paraffin in the tank.. about 250ml for a full tank .. every time you fill up to act as an injector cleaner .. (or use Red-X etc. if you want more or less the same thing for 400% of the price.. )

Finally if it none of this works, get some Octane Booster (or fill up a whole tank with 99 or 100 Octane "Plus" fuel.. I believe Tesco's and maybe Esso flavours are best) and see if the pinking goes away. If it's still doing it with 100 RON petrol, then whatever the noise is, it's *unlikely* to be pinking.

Ralf S.

No bullets for Chaingun..
Ralf S. is offline  
(Post Link) post #3 of 4 Old 24-09-14 Thread Starter
Status: -
AO Member
Join Date: Apr 2010
Location: United Kingdom
County: Surrey
Posts: 96

Member car:


Thanks Ralf

Very interesting.
lo42 black 944 is offline  
Status: poly n moly! Have you?
AO Member
Join Date: Feb 2014
Location: United Kingdom
County: Essex
Posts: 831
Clean your map, air mass meter n throttlebody, check your engine vac lines. They should always be done every year in the service, but lots get neglected. A clogged or faulty EGR can cause this. Try Cataclean in your tank n go for a blast once its up to temperature. You could have a loose or over tight knock sensor, or its wiring is recieving interference from a hot surface or another wire/HT voltage source! Do the cleaning and if it carries on seek professional diagnostic?
MULTIVITZ is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146ti , alfa , pinking , warm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome