front brake pads 146 98 1.6 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 23-01-07 Thread Starter
Status: -
Join Date: Aug 2006
Posts: 5

Member car:

146ti 1.6

Help front brake pads 146 98 1.6

fitted front pads caliper now rubs inside wheel and have soft pedal
diablo99 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2003
Location: surrey
Posts: 41

Member car:

146 18ts

Re: front brake pads 146 98 1.6

Just a guess and I dont know about the soft peddle maybe you need to bleed them again but I had a problem with the caliper rubbing the inside of the wheel slightly when I had the tyres changed, the caliper was hitting the new balance leads just a fraction. I had changed the pads about a month earlier.
nattyantlers is offline  
Status: -
AO Silver Member
Join Date: Jul 2004
Location: United Kingdom
County: Derbyshire
Posts: 5,583
Re: front brake pads 146 98 1.6

Originally Posted by diablo99
fitted front pads caliper now rubs inside wheel and have soft pedal
Fitting new pads shouldn't allow air into the system, so the 'soft' pedal may be cased by incorrect fitting. It may just be that the new pads have different characteristics to the old ones which gives a different feel to the pedal.

Take a wheel off & find where the rubbing is occuring - as nattyantlers has said, it will probably be the balance wights which are rubbing, in which case it's nothing serious. The calipers may just be sitting a little higher off the mountings with the new pads; did you clean the rust & crud off the pad locating faces on the caliper when you fitted the pads? If you didn't, clean them with a wire brush or wire wool. A little bit of filing on the pads may also be required to allow the caliper to sit a little bit lower.

Assuming the pads have been correctly fitted, it's just a matter of finding a fraction of a millimetre to restore the necessary clearance - it really is that tight!
Dave Brand is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , brake , front , pads

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome