Crazy Electrics - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 02-10-06 Thread Starter
Status: -
AO Member
Join Date: Feb 2004
Posts: 39
Crazy Electrics

My electrics have started to behave very Italian like ! Since friday my windscreen wipers sometimes will not turn off (front and rear) and my central locking now appears not to work, the doors lock but not centrally ! I have checked fuses etc looks ok, any ideas would be most appreciated.
bobulos2 is offline  
Sponsored Links
Status: -
AO Member
martyn145's Avatar
Join Date: May 2006
Location: United Kingdom
County: Suffolk
Posts: 117
Images: 8

Member car:

156 1.9 jtdm

Re: Crazy Electrics

With the door lock mine stopped. after lots of mucking around I gave them a squirt of WD40. Been fine since. they just get full of crap. Not sure about the wipers.
martyn145 is offline  
(Post Link) post #3 of 3 Old 03-10-06 Thread Starter
Status: -
AO Member
Join Date: Feb 2004
Posts: 39
Re: Crazy Electrics

wd40 did the trick ! thanks
bobulos2 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

crazy , electrics

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome