Bonnet Pull Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 26-07-06 Thread Starter
Status: -
AO Member
Join Date: Feb 2004
Posts: 39
Bonnet Pull Problem

Whilst trying to resolve my oil cap issue I managed to close the bonnet with some gaffer tape still on top of the engine so it didnt shut / open properly, I eventually managed to open the bonnet but in doing so the bonnet pull lever in the dash came off. It doesnt look like its broken but it does not seem to want to go back into place, any tipe would be most appreciated.
bobulos2 is offline  
Sponsored Links
Status: -
AO Silver Member
McGuinn's Avatar
Join Date: Mar 2003
Location: Dublin, Ireland.
Posts: 3,194

Member car:

145 1.8 TS

Re: Bonnet Pull Problem

This is a complete PIG of a job.
I had to release the wire from the bonet hinge (easy) and then pull the wire in the footwell back a little to give me some slack.
I then connected it to the release handle as normal, and then had to use tremendus force to shove the handle back into the 'fulcrum' or pivot joint from where it came.
It was so hard to do that I even tried removing some excess plastic off the circular pivot to lessen the force required to reseat it.
It took about an hour of bending backwards into the footwell to fix it.

Pure pig. (Feel the hate...)

For Sale: Alfa Romeo Spark Plugs - NGK laser platinum, 10mm & 14mm. PM me.

"And now my friend, the first rule of italian driving. Whatsa behind me is not important."
McGuinn is offline  
(Post Link) post #3 of 4 Old 26-07-06 Thread Starter
Status: -
AO Member
Join Date: Feb 2004
Posts: 39
Re: Bonnet Pull Problem

mangaged to get it back on quite easily eventually! I spent over an hour this morning and it just wouldnt go on at all no matter how much force I used, I tried again this afternoon and it just popped back into place, hope it doesnt happen again !
bobulos2 is offline  
Status: -
Join Date: May 2007
Posts: 5

Member car:

156 Spurtwagon

Re: Bonnet Pull Problem

I've also got a bonnet problem My '03 159 sportwagon bonnet will not open.

Tried stripping the pull lever to get extra pull on the cable

Tried push - pulling the bonnet whilst someone is puling the cable

only thing I haven't done it attach with a 4lb hammer

Any ideas?, was serviced in Feburary and getting a bit nervous about the oil level now.

All advice greatly appreciated.

edit > just realised I'm in the wrong sub forum sorry.
anteater is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

bonnet , problem , pull

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome