Overheating 146ti - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-05-06 Thread Starter
Status: -
AO Member
Join Date: Nov 2003
Location: Canterbury, England
Posts: 23
Overheating 146ti

The fan on my 146ti is not cutting in - trying to find the sensor that operates it - can anyone tell me where to locate it plse?
alfa.romeo164 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Overheating 146ti

Youmay have a fan switch on the bottom right of the rad (as you look at the engine) but if it's a later model some were controlled by the ECU from the water temp sensor I think.

See if you can find a power wire and earth for the fan to check it actually works. Oherwise it'll probably be the fan switch/water temp sensor.

Status: -
AO Silver Member
Join Date: Aug 2003
Location: Bristol
Posts: 5,002
Re: Overheating 146ti

Have you checked the fuse?
mave is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146ti , overheating

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome