Clutch! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 23-02-06 Thread Starter
Status: -
AO Member
rupertthedog's Avatar
Join Date: Apr 2005
Location: Suffolk
Posts: 102
Hmmm Clutch!


146 1.8 TS - Getting slightly screaming noises when releasing clutch (particularly in traffic when releasing slowly), and slight "crunchiness" when gearbox cold-clutch going?? If so can anyone advise how much for a new one?
rupertthedog is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Clutch!

Clutches are about 150 for the parts but it's a bit of a pig to replace. I would guess about 4-500 all in.

Status: -
AO Member
Join Date: Jun 2002
Location: United Kingdom
County: Cheshire
Posts: 443
Re: Clutch!

It MIGHT not be the clutch on the way out. I have had similar problems in the past, but not the squeaking and crunching at the same time.

For crunching, make sure that the slave cylinder and all linkages are behaving as they should.

As for the creaking... I had this very same problem last week. It sounded awful and really annoyed me - the car is currently for sale.

A quick poke under the bonnet while the wife depressed the clutch revealed the problem: a linkage on top of the clutch body was making the noise. A bit of grease and the problem was soon gone.

156 2.4jtd working it's way towards perfect condition. Loving the diesel warpage!
Rich T is offline  
Status: -
AO Silver Member
glenda's Avatar
Join Date: Jul 2005
Location: Co.Tyrone, N Ireland
Posts: 1,624
Images: 6

Member car:

145 1.8 T-Spark

Re: Clutch!

Rupert, if you check my thread called "Whirring clutch" in the 145 forum you may get a few more pieces of advice, as mine is playing up too. I've spoken to a mechanic about it and he reckons it may be a bearing at the Thrust plate.

My car is going in for a LOT of TLC next week as I'm getting REALLY ticked off with the clutch, rear wheel bearings, brake lines need replaced and god only knows what else. so I'll keep you posted on the clutch bit anyway
glenda is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome