HELP!! My 146 N/S/F door wont open from the outside!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 13-01-12 Thread Starter
Status: -
Join Date: Jan 2012
Location: United Kingdom
County: Somerset
Posts: 1

Member car:

Alfa 146 ti

Wave HELP!! My 146 N/S/F door wont open from the outside!!

Good Evening All!!
This is my first post - and sorry it has to be a HELP me moment!! My NSF door won't open from the outside!! It still loks with and without fob, it still opens from the inside. I'm going to try and have a look tomorrow..... But I would really appreciate and comments and advice that may help me find what to look for first! My 146 is due for MOT in 2 weeks, so need it fixed!!
Thanx for reading - hope someone can help!!
Hayziefantayzie is offline  
Sponsored Links
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Hi welcome

most likely to be one of the connector rods come loose, or the plastic connector that joins it all up has broken, easily done if the door has frozen up.

To look at it you need to remove the door card, which is a it if a fiddle. Pop off the plugs in the door handle and undo the bolts there, pop of the square-ish plug by the interior door handle to reveal another screw there, then most difficult of all, remove the speaker grille, the plastic tabs clip on, but getting them off in one piece needs care. There may be IIRC a couple of screws at the bottom of the door card, undo them, then pop the door card off the door with a spreader or large screwdriver, something that spreads the load, small and sharp will cause damage. Once the poppers are all undone lift the card upwards off the top channel.

You can now access the lock by peeling back the plastic cover and begin to see what the problem is.

IIRC there is a how to on the site, but you will need to register to see it

purple145 is offline  
Status: Off to Oz, bye UK !!
AO Member
Chardy's Avatar
Join Date: Apr 2010
Location: United Kingdom
County: Hampshire
Posts: 382
Images: 18
Mine do that when it's freezing weather but not sure why, I just pull the handle as soon as I hear the lock click. I have to be quick and it takes a couple of tries. It's fine most of the time ???
Not sure if yours is the same problem but good luck !
Chardy is offline  
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
No.. yours sounds like a sticky Central Locking.

You need to take the door card off and dry out the electrical connector .. and then spray some water dispersant into it. The lock mechanism itself probably could do with some fresh grease too.

The OP's problem is not related.. they have a lock/handle issue..

Ralf S.
Ralf S. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , door , n or s or f , open

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome