Injector Light! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-01-05 Thread Starter
Status: -
AO Member
Join Date: Aug 2004
Posts: 17
Injector Light!

Hi, can anyone help.

My injector light is coming on intermittently. It seems that the following conditions need to be met for it to come on:

Car need to have been left standing for at least 48hrs after a long journey.
Then after about 20 seconds after the engine has been started the injector light will come on. The light will stay on for about 5-10mins until the temp meter needle moves above the second dash. The light will then flash on and off afew times in 10 second intervals and then go way. Not to return again until the car is left standing for around 48 hrs.

Car seems to be running fine and fuel usage seems normal.

Any ideas?


AlfaAddict is offline  
Sponsored Links
Status: -
AO Silver Member
McGuinn's Avatar
Join Date: Mar 2003
Location: Dublin, Ireland.
Posts: 3,194

Member car:

145 1.8 TS

Re: Injector Light!

Lambda heater faulty? There was a test method posted here recently.
Believe it's to measure the resistance between the grey wires running to it. Should be low like 1.6 ohms.
McGuinn is offline  
Status: -
AO Member
Join Date: Apr 2003
Location: Kuala Lumpur, Malaysia
Posts: 29
Re: Injector Light!

I think the Engine Coolant Temp sensor is faulty.
Zahir is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

injector , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome