bad luck - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 24-11-11 Thread Starter
Status: -
AO Member
146cloverleaf's Avatar
Join Date: Dec 2010
Location: United Kingdom
County: Dumfries and Galloway
Posts: 162

Member car:

156 2.5 v6

bad luck

well i have just fitted 2 wishbones, 2 track rod ends, fan belt, oil flter, air filter, fuel filter, rocker gasket and spark plugs. took two days to do with 3 bolts snapping (one being on the head but got it out ) and my local parts supplier sending the wrong track rod ends.
Then 2 hours after doing all that tried to go over one of those silly speed bump things that you can get a wheel either side off and it was too high. result = hole in exhuast and shortly after that the thermostat stopped working.
love my alfas but this is starting to do my head in now.
thank god its payday tomorrow
146cloverleaf is offline  
Sponsored Links
Status: -
AO Silver Member
alfizta's Avatar
Join Date: Jun 2008
Location: Portugal
County: -
Posts: 2,631
Images: 10
be gentle with her, please
alfizta is offline  
Status: -
Adeebo's Avatar
Join Date: Oct 2007
Location: Cape Town
Posts: 5
Images: 20

Member car:

Alfa Romeo 145

defintely bad luck, it could probably smell that paycheck and wants some TLC
Adeebo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

bad , luck

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome