Idle problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-12-04 Thread Starter
Status: -
AO Member
Join Date: Jun 2004
Location: Taastrup, Denmark
Posts: 27

Member car:

146 1.6 Boxer

Idle problems

Hey guyz.
Just to sum up the problem, it all started with my engine juttering when driving, then the idle was to high, then the injector light switched on ... off again and the car worked fine ... until this morning the car went out every time it went to idle, so i had to turn on the car at every light and then step lightly on the gas to keep the engine running ... at some point the idle worked fine again, but question now is for how long.
Is anyone here familiar with doing diagnostics on the idle stepper or did anyone have similar problems with their boxer engine ???

I was told the price for a new idlestepper is around 130 excl tax here in DK so if I can avoid that I'll do that ...

Image is nothing,
Alfa Romeo is everything.
Dragon146 is offline  
Sponsored Links
Status: 0.9 turbo power....
AO Silver Member
p17sut's Avatar
Join Date: Nov 2004
Location: United Kingdom
County: Fife
Posts: 3,221
Images: 33

Member car:

500 twinair

Re: Idle problems

I've had similar problems with mine a few times.

The stepper and faulty sensors!

Usually check the stepper and just take it off and free off the valve flap with some oil. Works for quite a while again and ive done this twice so its free so alot better than replacing with a new part!
p17sut is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

idle , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome