146 is overheating - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-08-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: Croatia
County: Dubrovnik-Neretva
Posts: 1

Member car:


146 is overheating

Hi guys,

I'm starting to have a little problem during these hot days (I'm from Bosnia); my car suddenly started to overheat a month ago when outside gets quite hot (during the day approx. 33-37 degrees).

When I look at temperature gauge, I'm getting >85 degrees; after that (in some occasions), the car shuts off during the slow drive (or while idling) without showing any warnings on control board. Any idea what could be? Could ECU show anything interesting for this case?

During high speeds, temperature is lowering and is increasing when car would slow (second gear) or idle. Cooling fan would be turn on automatically and be turn off after some time.

I have 146 TwinSpark 1.6 from 1998.

I checked http://www.alfaowner.com/Forum/alfa-...1-6-boxer.html but couldn't notice that pawelk's car would turn off when it gets overheat.

Any help would be appreciated
dig666 is offline  
Sponsored Links
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
It sounds like the fan is working okay, since it comes on when the engine gets hot, cools the engine down and then turns off again.

What temperature is teh engine when it cuts out? Is it off the scale? If it's just 85-90C on the gauge (the gauge usually reads low) then it should be fine. 90C on the gauge is around 100C in reality.. and the engine should be still running, even beyond that temperature.

When it's hot though, the engine will lean out the mixture.. if there's anything weak in the system it could be starving the engine of fuel.

I'd start by looking at the MAF sensor to make sure it's clean. It may be worth cleaning the injectors too (put 250ml of paraffin or injector cleaner in the next tank of petrol).

It could be an electrical issue (coil?) but there are 4 coils and if just one was breaking down, the engine would probably still run.. so look at fuelling problems first.

Ralf S.

No bullets for Chaingun..
Ralf S. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , overheating

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome