Weird fan probs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 20-06-11 Thread Starter
Status: Helpingly Hopeful
AO Member
alfamender's Avatar
Join Date: Feb 2010
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 166

Member car:

Rover 420 i.s

Weird fan probs

Hi. Trying to sort ot a fan/overheating prob.

1. Changed waterpump
2. Changed Thermo switch in rad.
3. Changed thermostat
4. Fan comes in at 105 degrees for about 11 seconds but engine temp still rises to point of overheating.

Anyone any ideas
alfamender is offline  
Sponsored Links
Status: -
AO Member
Pujazuba's Avatar
Join Date: Aug 2009
Location: Iceland
County: Austurland
Posts: 585

Member car:

156 JTS

What car is in question here?
Pujazuba is offline  
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
I think you have air in the system, so check the radiatore for air. Is it hot all the way to the top, or just half way up?

If you bleed it (cold) does air come out?

The temp sender for the gauge is probably next to the thermostat .. and it's *hot* in there...

The fan is controlled by the sender on the radiator.. and the air in the rad is just merely hot.

The rad' fan comes on, cools the air in the radiatore a bit.. and switches off again. Meanwhile, the engine is still boiling, since the coolant can't get into the rad'. Your hoses are probably rock-hard.

Head gasket is knacked by the sound of it.. I have a number somewhere of a fella whose full-time job is fixing Rover K-series head gaskets.. and he's booked up for 3 weeks in advance... so you can see where it's heading. But it's quick and not toooo dear to fix.

Ralf S.

No bullets for Chaingun..
Ralf S. is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
couple of other things to check,

the fan relay, tucked under the front cross member, although if your fan is coming on, it sounds unlikely, second, the condition of the radiator, they crumble as they get old, particularly in the areas that are hardest to see, the bottom and behind the fan., goes a crusty green colour.

purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

fan , probs , weird

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome