146 TS engine ALMOST goes pop - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
146 TS engine ALMOST goes pop

Some time ago, I ran my 146 TS very low on oil due to excessive consumption... I was fortunate to check the oil because of a premonition I guess, but when i filled it up it took almost 3.5 qts!!

Turns out, this oil consumption was caused by a blown valve (and not the piston rings or cylinders like i initially thought ) Maybe from some over heating...

Anyway, the Low Oil warning never came up... its been talked about in the "Bestest oil" thread, plus i've read scary stuff happening here:
http://www.alfaowner.com/Forum/showthread.php?t=27917 (147 engine gone pop)

So... under what conditions does the low oil warning come up

Also, I live in a warm climate... does anybody know a way of adjusting the thermostat, so that the fan jumps in, say 10 earlier (without having the fan ON full time)??

Lower temp will use more fuel, but my engine runs too close to boiling the coolant, so there is almost no warning time before the engine is "melting and boiling stuff"...

thanks in advance!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , engine , pop

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome