Radiator fan short - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #26 of 26 Old 13-01-05 Thread Starter
Status: -
AO Member
Join Date: Aug 2004
Posts: 17
Re: Radiator fan short

Well, new fan is in and working (again). Lets hope this one doesn't go the same way as the others!

Thanks everyone for your help.

Here's the story:

Took car into Alfa specialist to check out before taking car into main dealer (where I purchased the rad fan from), just to get them verify that there was nothing wrong with my car that could be causing the rad fan to blow (didn't wan't the main dealer making a fault up). Told the specialist that the injector warning light was coming on and this could (possibly) be related so could they look at it. Injector light came on when the car hadn't been used for a few days, until engine warmed up, and when engine got very hot (i.e. when fad fan should be on, however was not on because it had blown the fuse). Specialist said that the faultly fans seem to has caused over heating of the fan circuit which was causing the injector light to come on (fixed with an hours labour charge, a fuse and two relys - 60). However nothing wrong with the car which would cause the fans to blow. the relays seemed to be working fine to me (injector light came on when fan was still working), but I went with it!

So took car into main dealer and re-iterated that I would not be paying for them to look at the car, they wanted to look at it because they we disputing my warrenty clain for the fan.

Next day (they had to order a new fan) the service manager informs me that they have replayed the fan, cleaned an earth conection, replace melted connectors to the reistance fan and replaced 40A fuse (I put a new one next to the drivers seat which they must have blown as part of their diagnostics!). So he tried to charge me for the parts and labour! Had an argument regarding if the 'faults' found would have casued the fans to blow. Resulting in me paying 10 for the parts and nothing for labour, and the service manager informing me that I was 'out of order'!
Picked up the car, check under the bonnet to find that the live terminal protector on the battery ws missing, a quick search by the service guy and it was found in a tool box!

Anyway got a call from the parts department a few days later, they were looking for my original invoice for the rad fan (which I had given to them a few days back) so thay could make a warrenty came with alfa!

So there you go. Oh and of course the injector waring light still comes on when cold as before (i'll post a new messgage on that one!).

AlfaAddict is offline  
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

fan , radiator , short

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome