Alfa 146 TS 1.8 - Injector warning symbol - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 19-02-11 Thread Starter
Status: Is Alfaless for a couple of weeks, see you then x
AO Member
susyhun's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: Northamptonshire
Posts: 15
Images: 2

Member car:

146 TS 1.8

Help Alfa 146 TS 1.8 - Injector warning symbol

Hi Guys!

Fitted a second hand Bosh MAF last year, car ran OK, no warning symbol, but wouldn't idle properly (hunting from 500 - 2000 RPM twice, then settles at 900). Last week for no apparent reason, the injector warning symbol came on and is now permanent. I've bought a new MAF (copy), but light stays on and still wont idle. Followed your link to reboot the ECU, but still no change. Any ideas?

Also Id like to change my gearbox oil, does anyone knows the special tool (Alan key) to take out drain plug (very inaccessible)?

Thanks for any help!!!
susyhun is offline  
Sponsored Links
Status: -
lovely146's Avatar
Join Date: Mar 2011
Location: Zimbabwe
County: Harare
Posts: 7
well i do not know anything about the gearbox drain plug but my 146 had an idle problem aswell and i was told to remove the throttle housing and when you do that remove the IDLE STEPPER MOTOR from the throttle housing. when you remove it open it carefully and clean it properly with carb cleaner.. when you are done put everything back together and you should be fine... i did tha same with mine and she runs beautifuly
lovely146 is offline  
Status: -
Join Date: Mar 2011
Location: United Kingdom
County: Isle of Wight
Posts: 2

Member car:

146 2.0 TI

Have You Fixed It ?

new to the forum, having similar problems so wondering if you've been able to fix yours yet ? if so, how ?

Gift of Gab
GiftOfGab is offline  
Status: -
AO Member
xyy81t's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Oxfordshire
Posts: 292

Member car:

2.4 Lusso 159

well first off, do not remove the stepper motor from the throttle body unless you're prepared to pay someone 50 notes to re-calibrate it once re-fitted.

remove the throttle body and clean the butterfly valve if that doesn't help then a new ICV/TPS (stepper motor) is required
xyy81t is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , alfa , injector , symbol , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome