Alfa's 145 1,4ts idle - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-10-10 Thread Starter
Status: -
AO Member
nikits's Avatar
Join Date: Oct 2010
Location: Greece
County: Attica
Posts: 36
Alfa's 145 1,4ts idle

Hello my friends.

I'll try to say what i want, in words you can understand because I don't know the spacific words in english for many car parts and also don't speak very good english .

i have a problem with the idle.

When i start the engine everything is ok. I recently changed the MAF with a new one and all the problems seemd to have solved, but.... not.
From the first day after MAF change, the engine runs properly while "travelling" (i try to say when the car is moving) in any gear and any range of engine speed.
But in every start up and after 2-3 min of warming up, the engine's speed goes crazy with the rpms going up and down from "Zero" to 2,500.

Is it the stepper motor? Is it something else?

Thanks in advance

i would like to be, what i was, when i wanted to be what i'm.
nikits is offline  
Sponsored Links
Status: 100% Alfa Free :(
AO Silver Member
groovylee's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Bedfordshire
Posts: 4,097
Images: 77

Member car:

A Motorbike ;)

throttle position sensor maybe? i think there are a few threads on it in here if you do a search?
groovylee is offline  
Status: -
AO Member
Pujazuba's Avatar
Join Date: Aug 2009
Location: Iceland
County: Austurland
Posts: 585

Member car:

156 JTS

I have experienced idle speed of that magnitude before, but only once. It never happened after changing the MAF and stepper motor, so I can only point out to one of those.
Pujazuba is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

145 , 4ts , alfa , idle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome