problems with crankshaft belts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-07-10 Thread Starter
Status: -
Join Date: Jul 2010
Location: Greece
County: Peloponnesos
Posts: 1

Member car:


problems with crankshaft belts

hey guys!i am new at the site and i join here because i had some problems with my alfa, so i ask for some help.i own a ar 146 1.6 8v boxer engine and i had some problems.the engine is not performing makes strange noises, uses more gas than it should be, it has lost almost all of its horsepower etc etc etc.these problems have started when i changed the belts the ones that are covered with plastics,connecting the crankshaft with the camshafts.i am from greece so my english is not so good.i want to ask if anyone know what kind of problems can i have if the belts are not correct and i also want to know(i have download the workshop manual but the internet translator is not very helpfull..) where the flywheel timing mark number 1(at the manual) is.thank you
xrifil is offline  
Sponsored Links
Status: faclifting a 156
AO Silver Member
biffa's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Images: 9
Sound like it not timed right...
This might be of use???
biffa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

belts , crankshaft , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome