Dashboard lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 12-06-10 Thread Starter
Status: -
AO Member
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 11

Member car:

Alfa 145

Dashboard lights

Last week my 145 engine would not stop running even when I removed the key. To stop the engine I disconnected the battery. No when I connect the battery all the dashboard lights come on immediatly - with no key.

Any ideas ?

Alfabakkie is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2003
Location: Bristol
Posts: 5,002
Take a look at the group of relays under the bonnet - these are prone to corrosion, might be causing teh problem?
mave is offline  
Status: Go to forum.alfa145.com
AO Silver Member
Join Date: Jul 2005
Location: I would rather not say
County: -
Posts: 1,503
Water getting into the back of the fusebox (a known issue on these cars) is the most likely cause as that is where most of the electrics get routed. A short circuit in there can cause all sorts of wierd things to start happening with the electrics.
GialloEvo94 is offline  
Status: faclifting a 156
AO Silver Member
biffa's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Images: 9
Make sure you have the correct bulb fitted in you brake lights... i.e twin fliment not single...
biffa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

dashboard , lights

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome