Clicking noise from dash area - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-11-09 Thread Starter
Status: Waiting for Spiderweather
AO Member
luckydog's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: Suffolk
Posts: 212
Images: 12
Clicking noise from dash area

Hi all,
Have just bought a 2.0 145 Cloverleaf for my daughter and after checking it all out found a few problems which I have mainly been able to fix but this one is baffling!
There is a regular 'clicking' sound coming from rear of glove box area, clicks about once every 3 secs. Thought initially it was to do with heater but with fan switched off, it still occurs. Any ideas?
It doesn't always do it immediately car starts, sometimes will be a few miles from starting.

Thanks for your time,
luckydog is offline  
Sponsored Links
Status: I still miss my V6
AO Member
Biggles146's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Hampshire
Posts: 394
Images: 21

Member car:

159 TBi ti

Hmm, weird. Has someone moved the fuel pump and main relays inside the car? They commonly rust up and would usually be located under a cover in front of the battery.

Id imagine the fuel pump relay could trigger this often.
Biggles146 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

area , clicking , dash , noise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome