ALFA 147 JTD Electrics HELP!!!!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-07-09 Thread Starter
Status: -
Join Date: Jul 2009
Location: United Kingdom
County: Wiltshire
Posts: 3

Member car:


Help ALFA 147 JTD Electrics HELP!!!!!!

I am having a few issues with my 05 Alfa 147. Every now and then the front electric windows and the boot release will stop working I remove the 15Amp fuse which does not blow when the problem occurs, replace it and the problem is solved.

Could anyone give me an idea to what could be causing this, also sometimes when starting i hear a clicking sound coming from the area of the fuse box could this be part of the problem.

Many thanks
jonm is offline  
Sponsored Links
Status: Zoe FTW
AO Rosso Alfa Member
baby278278's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Essex
Posts: 46,602
Images: 49
Wrong lounge Fella , you might want to post this in the 147 area instead of the 145

(unless a mod can move this thread and delete my post )
baby278278 is offline  
Status: -
AO Platinum Member
156Chris's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Surrey
Posts: 12,877
Images: 12
Well from your diagnostics it would seem that you either have a dodgy connection with the fuse (in which case put some electrical contact cleaner on it ... or put a difference fuse in) ... or there is a dodgy connection somewhere else in the fusebox and by removing and replacing the fuse you're getting the connection back ...

... not much help, but it does seem like you've isolated the problem ...
156Chris is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

147 , alfa , electrics , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome