Heater Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 01-07-09 Thread Starter
Status: -
AO Member
craig_87's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Merseyside
Posts: 96

Member car:

146 Junior



My heater has been stuck fully on hot since I bought the car in December. Obviously with current "heatwave" conditions, the car was beyond a joke to drive... so decided (with my dads help and guidance ) to have a go at trying to fix it.

Took the middle lining part of the dash out to have a look, and was clear that the problem was the standard broken white clip that most 146s seem to suffer (Such a small pointles plastic contraption...surely they should have known??)

Had a play around with that, pulled the wire downwards (after struggling to shove my hands up there) which amazingly changed the temperature of my blowers... now cool enough to chill in summer... possibly warm enough in winter to be comfortable.. who knows.

However, unfortunately during the process.. I managed to disconnect the heater matrix end of the wire... from the matrix itself

Im guessing Im going to have to remove the majority of the dashboard to get at the matrix enough to reattach.
Does anyone have a simple guide on how to remove it and hopefully to reattach the cable? Preferably not too difficult HAHAHA..

Last edited by craig_87; 03-07-09 at 10:24.
craig_87 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

heater , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome