alfa 145 cloverleaf seems slow - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 20-05-09 Thread Starter
Status: -
AO Member
trem3412's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Buckinghamshire
Posts: 39
Images: 7
alfa 145 cloverleaf seems slow

HI guys brought a 145 qv after having 5 155's lol cant beat an alfa
when i first got it it was quick i have since fitted a induction and a full stainless steel exhaust including decat and it now seems very hesitant through the rev range but this is not all the time.i know its not the maf as i have tested this any idea would be great thanks.
trem3412 is offline  
Sponsored Links
Status: Want your car undersealing? PM ME!
AO Silver Member
langers's Avatar
Join Date: Apr 2008
Location: Lincoln
Posts: 1,929

Member car:

145 Cloverleaf

Re: alfa 145 cloverleaf seems slow


I would of suggested the MAF but you have already tried it.
langers is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Re: alfa 145 cloverleaf seems slow

coil pack, esecially by cylinder No 1 gets my vote.

purple145 is offline  
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: alfa 145 cloverleaf seems slow

The mods you've done will have altered the flow of gases through the engine, the TS is very picky about this and they need quite high back pressure to run smoothly.
Smaky is offline  
Status: Go to
AO Silver Member
Join Date: Jul 2005
Location: I would rather not say
County: -
Posts: 1,503
Re: alfa 145 cloverleaf seems slow

If you're sure the lambda and MAF are definitely OK (and you also don't have any problems with a possible dodgy coolant temp sensor) then with the mods you've done it would be a good idea to think about maybe getting a remap done so the ECU map is tailored to match the changes you've made to the cars intake and exhaust systems.
GialloEvo94 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

145 , alfa , cloverleaf , slow

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome