What a week... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 15-05-09 Thread Starter
Status: It all works, mostly
AO Member
Join Date: May 2009
Location: United Kingdom
County: Derbyshire
Posts: 11
What a week...

Well... Completed the Italian Tune-up of my car about 1.5 hours ago, yes working into the night for me! It now has new variator, new belts and tensioners, new clutch, new lambda, new anti-roll bushes, new tyres, new radiator and probably knows a lot more english swear-words than when it entered the workshop on Tuesday! I mean seriously, what drugs were they on when they designed the suspension/driveshaft/engine mount mess?!

It all started last week when the clutch decided it didn't need all of it's springs and left me revving and easing up and down the range on the way back from spending quite a lot of money on parts! I started by attempting to remove just the gearbox, but ended up removing the engine from the car because instead of buying a vehicle lift and making life oh so easy, I keep spending money on bits of Alfa!

So, now after a long couple of days, and some extreme boredem from the other half, its alive and well again!

So firstly, if anyone wants probably not so much advice, more of a "Wot I done next was..." guide, I have a load of pics taken in between swearing, coffee breaks and throwing tools! I ended up lifting th'engine out rather than dropping it VW Beetle stylee. Once it was out, it was very nice to work on. Just a complete nightmare to get out and back in!

Secondly, I managed to get some quite good deals with proper parts (if anyone is interested) off of Autoworld in Chesterfield and Th'Ebay. All apart from the rad, that I got from somewhere else in Chesterfield. It's not an original (its for a Fiat Tipo and Tempra) and it also came with 2 sensor holes. Then I found I could have got it much cheaper from Heanor Radiators, off of Heanor, who supplied the blanking bits for the extra holes. Oh, and I don't work for either of these companies, I just got some good deals!

Thirdly, if anyone can correctly guess the next bit to fall of my cr*p car, you will win all the bits that I have replaced (minus the tyres and postage!) I've also recently replaced the wipers, exhaust, stereo and air freshener so these bits don't count!

140k miles and all is gravy!
Finterprise is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome