146 Handbrake - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 07-04-09 Thread Starter
Status: -
Join Date: Apr 2009
Location: United Kingdom
County: Greater London
Posts: 2

Member car:

Alfa Romeo 146

146 Handbrake

Hi All,

I've just found this forum and I am hoping that it will be useful to me, and perhaps my views to others.

I have a lovely 146 1.6 TS that still runs well but if finances were different I would replace her.

A recent visit for an MOT found that the handbrake was just below the minimum holding load. This is surprising to me as all brake pads were changed just before Christmas.

I would appreciate any suggestions as to why this is the case before I take her into another garage for repairs.


Chloe is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: 146 Handbrake

Moved to 146 section

Good luck
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: 146 Handbrake

If you fancy poping over then I'll sort it out for you.
Smaky is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Re: 146 Handbrake

pretty easy and cheap fix I should think.

Smaky is your man if you are not too far away, in fact by the time he has worked his magic, you will want to keep it
purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , handbrake

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome