Alfa 145 cutting out - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-09-08 Thread Starter
Status: -
Join Date: Sep 2008
Location: United Kingdom
County: Bristol
Posts: 3

Member car:

Alfa 145 1.8 ts

Alfa 145 cutting out

Hi, I've just bought an Alfa 145 1.8 ts. The problem I have is that every now and again the car stalls when I dip the clutch. The car starts fine It idles erratic sometimes and when it does cut out it restarts fine. The car idles at 1000 rpm. I've cleaned the throttle body and when I diconnect the maf sensor the idle goes all over the place. Does anyone have any ideas?
simon08 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Re: Alfa 145 cutting out

Hi and welcome to AO

moved to 145 tech lounge
classicgal93 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

145 , alfa , cutting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome