146 2.0ti revs jump - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 29-07-08 Thread Starter
Status: -
Join Date: Jul 2008
Posts: 1
146 2.0ti revs jump

hi, i have a alfa romeo 2.0ti, lately when i stop at lights the revs jump up to 2500 and jump down like its about to stall, sometimes its fine but lately the problem has been getting worse, any ideas???
sush007 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: 146 2.0ti revs jump

Stepper Motor (also known as Throttle Postion Sensor) will require replacement; located on the side of the throttle body.

Try removal and cleaning first. Delicately!

Do a search on here - loads of helpful info
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: 146 2.0ti revs jump

Yep sounds like the IAC is on the way out, but this could also be a stuck variable intake valve.
Smaky is offline  
Status: -
AO Member
cloverleafer's Avatar
Join Date: Apr 2008
Location: Bradford
Posts: 330
Images: 4
Re: 146 2.0ti revs jump

Similar problem as what happened on my 145 2.0.. Got a secondhand throttle body off of a 2.0 146 and sorted problem straight away - only cost me £7.51 from ebay, bargain!!
cloverleafer is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , 20ti , jump , revs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome