Broken Rear Window Washer on a 145... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 13-12-03 Thread Starter
Status: -
AO Member
Join Date: Dec 2003
Location: Hertfordshire
Posts: 61
Broken Rear Window Washer on a 145...

Got my new 145 this morning - I haven't been able to take the grin off my face all day!!

Playing around with the controls I have discovered that the rear screen washer doesn't work - the motor is going but on closer inspection the water is coming out somewhere around the catch and running onto the ground from behind the rear bumper.

Does anyone know how this is routed so I can get at it and reconnect the hose? A similar thing happened on my old Golf so hopefully it is pretty easy...

I may take it back to the garage but it's a 60 mile round trip and if I can do it myself I'd rather save the petrol!!


Remember, if you have to ask the price... you can't afford it.
edgriffiths is offline  
Sponsored Links
Status: Bavarian
Admin Team
bobda's Avatar
Join Date: Jul 2002
County: -
Posts: 15,247
Images: 13

Member car:

Not a GT

You need to remove the hatch inner skin.

The pipe does occasionally come away.

While you are there, give the jets a clean, they are in a vulnerable position and get clogged easily.


bobda is offline  
Status: Daddy bear
Global Mod Team
bazza's Avatar
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 42,042
Images: 3

Member car:

Alfa 156 GTA SW

Hatch has two screws towards the bottom, and two bolts beneath the light covers, then just pray a little, and pull
It's just those press-stud thingies holding it on after those.
bazza is offline  
(Post Link) post #4 of 4 Old 14-12-03 Thread Starter
Status: -
AO Member
Join Date: Dec 2003
Location: Hertfordshire
Posts: 61
Fixed!! Absolute doddle - only took a few minutes to sort!!

Thanks for the advice - I am now officially an Alfa owner - had it for just over 24 hours and already doing running repairs!!
edgriffiths is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

145 , broken , rear , washer , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome