Dodgy accelerator cable routing... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 04-11-03 Thread Starter
Status: -
AO Member
Join Date: Jun 2002
Location: United Kingdom
County: Cheshire
Posts: 443
Dodgy accelerator cable routing...

The accelerator cable on my 1.7 145 snapped the other day.

No problem - it's a wear and tear item and I've managed to bodge it with bits of mountain bike cable until I can get hold of a proper one.

BUT while I was fiddling about, I couldn't help but notice that where the cable comes out of its sleeve is a terrible design: it causes the cable to fray (which is why it snapped) and it also stops the throttle from opening 100% when you have your foot flat down.

It looks like a fairly simple modification will improve it no end - just wondering if anyone has done this before, and if they have any pictures.

Also, I'd like to see pics from any 33 16v owners - wonder if the routing on the 33 might be a bit better?

Rich T

156 2.4jtd working it's way towards perfect condition. Loving the diesel warpage!
Rich T is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

accelerator , cable , dodgy , routing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome