Some new 155 questions. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Some new 155 questions.

I really love this forum. It's actually faster to post something here, than calling Alfa Romeo service. Hehe. So, here goes:

1. Yesterday, I was driving my 95 1.7TS up to a mountain (1222 Meters above sealevel) And these roads are verry challenging. I think the climbing rate is at 23%, and there's a lot of corners. Anyway, when cornering a sharp bend, there was a light that lit up that I had never seen before! This is a left hand drive car, and where the sensor for the AC is, there is also a little green light, that came on for about a second... Anybody know what it is?? For you that's not following. The sensor of the AC is just beneath the ignition switch... To the right of the steering wheel...

2. I live in Norway, by the fjords. It's really lovely here, but I have a question now when the temperature is dropping. How does the car handle steep hills at snow? Or do anybody have any comment on how the car is at snow?? I really would apreciate your answers. I know that the wheels makes the biggest difference. So if two people have identical cars, but one drives i.e X-tyres, and the other one drives Y-tyres, one car can be really good, and the other one sucks... But please give me your comments from YOUR experience...

Thanx, guys!
I'll be driviing my Twinny to the service tomorrow. The're going to have a service and fix my gearbox. Ouch!
Sponsored Links
Status: -
AO Member
speedy's Avatar
Join Date: Jan 2003
Location: The Twilight Zone........
Posts: 187

Member car:

ALFA 155 V6

Try doing a few searches over on you might get your questions answered there wink
speedy is offline  
Status: - Update
Posts: n/a
LOL Glad you said that Speedy wink

My experience of 155's in snow is not good. Found that anything steeper than a flat road leaves me stuck!

The handbook I've got says not to use snow chains, yours might be different though.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

155 , questions

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome