suspension 164 cloverleaf - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
suspension 164 cloverleaf

I have a 1995 164 cloverleaf with 102000 miles on the clock. I have not driven a new one, but the suspension is rather 'jiggly' and does not cope with bumps very well. Is this normal and does any one have any suggestions to improve this, i.e new shocks/springs etc?
Sponsored Links
Status: -
AO Member
Join Date: Mar 2002
Location: WSM UK
Posts: 518
Images: 6
Make sure your 4 wheels are aligned correctly, the cars are very sensitive to misalignment. Also your auto suspension control may be stuck in Sport mode. When you turn the key to stage 2 and press the TEST button (then release it) all lights should go out after 6 seconds, if the shock absorber symbol stays on for a further 15 seconds then it is stuck in Sport mode (hard setting) because a fault has been detected somewhere in the system.

Mike M is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

164 , cloverleaf , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome