00 alfa 146 t spark 1.4 rev problems please help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-06-08 Thread Starter
Status: -
Join Date: Dec 2007
Location: dublin ireland
Posts: 6

Member car:


00 alfa 146 t spark 1.4 rev problems please help

my car keeps reving up and down and the idle moves up in revs and back down again. im having a mechanic look at it tomorrow he said it sounds like the carburetor is dirty? can anyone tell me if i am about to waste money with this guy? the engine seems to be very load almost like a diesel engine. im not sure where to go with the car here in dublin if i go to an alfa romeo garage i was told the costs would be more than the car is worth
any information would be greatly appreciated guys ill be on line for the rest of the evening cheers mark.
frenchdub is offline  
Sponsored Links
Status: Go to forum.alfa145.com
AO Silver Member
Join Date: Jul 2005
Location: I would rather not say
County: -
Posts: 1,503
Re: 00 alfa 146 t spark 1.4 rev problems please help

There are no carburettors on the TS engines...they're a modern fuel injected setup controlled by an ECU

If your mechanic is suggesting carburettor problems then I suggest you might be better taking the car somewhere else because it's fairly evident that he's not worked on TS engine before.

The first thing you should do is try unplugging the MAF (Mass Air Flow meter) and see if it makes any difference to the running of the engine with it left unplugged. If not then next is to clean the throttle body. If that doesn't resolve the issue then suspect a faulty Idle Control Stepper Motor.

See the following post for more info and pictures...

Idling Problems - Alfa Romeo 145 - 146 Forum

I won't be posting on this forum any more. If you want to know why and/or you want answers to some 145/146 related questions then please feel free to pop over to and post on the alfa145.com forum where you will find me with the same member name.

I have now disabled all my private messaging options on here but you can PM me over on the alfa145.com forum if you need to.
GialloEvo94 is offline  
Status: -
AO Member
cloverleafer's Avatar
Join Date: Apr 2008
Location: Bradford
Posts: 330
Images: 4
Re: 00 alfa 146 t spark 1.4 rev problems please help

I had the same problem last month!

A few people on here suggested it could be a faulty stepper motor..
So i got my self on ebay and found someone who was selling a complete throttle body with the stepper motor etc on it and won it for 7.51 !!
Fitted it on the car and it sorted the problem out straight away!

If you want to change just the stepper motor I wouldnt bother, Id try and find someone on ebay who is breaking a TS engine and try get the stepper motor off of them - but fisrt ask them if the car was idling properly before they dismantled the car!

Hope this helps mate
cloverleafer is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

146 , alfa , problems , rev , spark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome