Clutch pedal - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Clutch pedal


I have a problem with my clutch pedal. A few days ago, it suddenly end up 4 inches higher. In this 4 inches, I hardly feel any resistance when pressing down the pedal. Looks like some sort of spring or fastener broke down. Any experience with this one? Can I fix it myself, or do I have to go to the dealer? What are the costs of something like this?


Sponsored Links
Status: -
AO Silver Member
McGuinn's Avatar
Join Date: Mar 2003
Location: Dublin, Ireland.
Posts: 3,194

Member car:

145 1.8 TS


The Clutch/Brake system share the same fluid, so while I don't think that you have run out of fluid (you would have brake problems!!!) you would want to check the reservoir. Bleed the clutch slave cylinder also (located above the clutch/flywheel) incase air has got past the seal. Check that the slave cylinder is pressing against the paddle which disengages the clutch.

Let us know how it's going after that!
McGuinn is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

clutch , pedal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome