alfa164 heating - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
alfa164 heating

i recently bought an alfa 164 back end of summer, graet car great drive.i have no heting ,the system has beenbled new thermostat and the garage bloke said the matrix is ok he thought it maybe something, maybe a switch right inside the dashboard but said he didnt have the equipment to sort it or maybe he just didnt want to do it . i would be grateful for your comments its getting cold now.thanx
Sponsored Links
Status: -
AO Member
Join Date: Mar 2002
Location: WSM UK
Posts: 518
Images: 6
Come on dude, a little more info please!

What model do you have? What year is it? Can you control fan speed? Can you redirect air from feet to windscreen?

Let us know

.....just hoping for your sake it is not the stepper motors.
Mike M is offline  
Status: - Update
Posts: n/a
thanx for your reply. the car is a 1991 2.0 twin spark 164. the fan control speed can be adjusted and the directional flow is ok too.
Status: -
AO Member
Join Date: Sep 2002
Location: East Lothian
Posts: 149
As mentioned above the problem sounds like the stepper motors which control the proportions of hot and cold air in the heating system.Do you get a clicking noise when the ignition is switched on?
The heater always receives engine temperature water and the stepper motors control the air flow temperature.
It is a fairly major operation to fix the motors(problem is a stripped plastic gear).There is a cd available describing the operation.Some people have managed a repair on the gear without removing the dash.
As a temporary fix it is possible to move the lever controlling the air mix manually(under the bonnet somewhere). You then have no control over the heating but you can get heat.
Ramian is offline  
Status: -
AO Member
scaligeri's Avatar
Join Date: Jan 2002
Location: southampton G.B.
Posts: 882

Member car:

alfa75V6 200hp

I had the same problem, if its the stepper motor
in the glove box then it took me 2hrs to get it out.And a hour to put it back.tricky bit is feeding it back through the smaller hole,in relation to the odd shape of the unit,then recliping the cables back in. rest is easy,well it was for me. good luck!!!.
scaligeri is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

alfa164 , heating

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome