Stiff accelerator peddle - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Stiff accelerator peddle

When I bought my 145 I noticed that the accelerator peddle would stick once in use. This makes the car very hard to drive during traffic, as I have to put my foot underneath the peddle and force it back to its normal posistion or it accelerates constanly.A Year on and I still haven't done anything to put this problem right.
Has anybody exsperienced this problem before, and if so how did you over come the situation ? Can this be fixed easily or is it better to take it to a dealer and have the work done proffessionally.

Please help...!!
Sponsored Links
Status: - Update
Posts: n/a
Could try oiling it, the mechanism may just be sticky. Either that or the spring has died which should be cheap as chips to sort out.
Status: -
AO Member
Join Date: Mar 2002
Location: WSM UK
Posts: 518
Images: 6
Get down right underneath so yer head is right under the pedals (or as close as you can get).

Take a can of WD40 with the little stawer attached and with a torch have a good prod around and see if something looks obviously wrong. Try looking for a return spring that may have broken or a piece of rubber trim that is stuck in the pedal mechanism. It could actually be in the engine bay end of the cable (I am assuming your model does not "have drive by wire")

Sticking pedals and stuff like that is usually something pretty simple cos it's all down to mechanics rather than messed up Italian wiring done by some crosseyed Italian at the Alfa factory.

Let us know how you get on.

'96 164 Cloverleaf

Now a Mercedes CLK 430 Coupe.
Mike M is offline  
Status: - Update
Posts: n/a
Had a little look at the peddle arm , where it returns into a plastic block with a bolt and added some WD40. left for a while but didn't change so ill strip it down and have a look at the spring as suggested when I've got some time. Thanx for the help guys much appreciated, ill let you know if there is any change.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 145 & 146

accelerator , peddle , stiff

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome